Mailing List CGatePro@mail.stalker.com Message #98078
From: Lyle Giese <lyle@lcrcomputer.net>
Subject: Re: DNS Failure on Mailing Lists
Date: Wed, 10 Jun 2009 10:18:29 -0500
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
Multi-home puts all sorts of issues in the mix.  And DNS does not like responses that don't come from the same IP the query was sent to.  Because of the issues with hackers trying to poison DNS cache, there is a good reason for that.

I have two T1's but they go to the same upstream provider and we are not multi-homed.  Multi-home can cause all sorts of wierd problems once you start hosting services.

Lyle

Andy Kunkle wrote:
Yeah good call. I do use MRTG and have 2 bonded T1's to the internet. It looks like we're seeing an average of 500k outbound and 300k inbound on that. 

The other monkey wrench in this whole setup is that we're mult-homed. And given how ISP's setup DNS servers to only respond to machines on their network, I thought that might be a problem. I have my firewall setup for fail-over for DNS, so maybe that's the problem. I'm requesting DNS to one ISPs server but coming from my other ISPs network... I don't know of a way to fix this though, without disabling the redundancy of having 2 connections. I still maintain that it has to be something on my DNS server.

Andy Kunkle
IT Manager
AIM Engineering & Surveying, Inc.
5300 Lee Blvd
Lehigh Acres, FL 33971
239-332-4569


  
-----Original Message-----
From: CommuniGate Pro Discussions [mailto:CGatePro@mail.stalker.com] On
Behalf Of Lyle Giese
Sent: Wednesday, June 10, 2009 9:42 AM
To: CommuniGate Pro Discussions
Subject: Re: DNS Failure on Mailing Lists

Andy Kunkle wrote:
    
Hey All,

I've posted something about this in the past, but the problem
      
persists and I wanted to see if anyone else has had problems with DNS
resolving.
    
I have a user who has about 15 mailing lists and some of those lists
      
have over 30 people. Whenever he sends a message it will just collect
in the queue, and every domain on the list says "DNS server failure"
    
This actually happens any time someone sends a message with over 10
      
recipients.
    
Now the strange thing is that when I go into the Queue and click on
      
the domain name, and click Release Now, it will send, no problem. But
that's the only way... otherwise it will just sit in the queue
indefinitely. Another problem is that in the case of a mailing list,
this delay causes another e-mail to be sent to the user stating that
there was an error in sending and that they need to reply to stay
subscribed. As you can imagine, this gets very tedious for the
receiver, since every time they get a message from my user, they also
get a bounce warning message.
    
I've changed the unsubscribe on non-fatal to 200 times and also set
      
the "Fatal" to process as non-fatal so at least they're not
unsubscribed, but it doesn't solve the problem.
    
I'm running my own DNS, and don't see any kind of errors in the log
      
on that server. I just don't know what the problem is. When I go to my
mail server and do an nslookup, or a dig, it works every time. I
thought it had to be a volume problem, but I'm not seeing a way to tell
that.
    
Andy Kunkle
IT Manager
AIM Engineering & Surveying, Inc.
5300 Lee Blvd
Lehigh Acres, FL 33971
239-332-4569



      
30 people is not many. What is the bandwidth of your pipe to the
Internet? Do you have any graphing on it to see if it's
overloaded(mrtg?)?

If your Internet pipe is overloaded, your DNS servers will have trouble
getting answers causing these symptoms. And these types of errors
usually won't show up in DNS server logs.

Lyle

#############################################################
This message is sent to you because you are subscribed to
  the mailing list <CGatePro@mail.stalker.com>.
To unsubscribe, E-mail to: <CGatePro-off@mail.stalker.com>
To switch to the DIGEST mode, E-mail to <CGatePro-
digest@mail.stalker.com>
To switch to the INDEX mode, E-mail to <CGatePro-
index@mail.stalker.com>
Send administrative queries to  <CGatePro-request@mail.stalker.com>
No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.339 / Virus Database: 270.12.60/2166 - Release Date:
06/10/09 05:52:00
    




#############################################################
This message is sent to you because you are subscribed to
  the mailing list <CGatePro@mail.stalker.com>.
To unsubscribe, E-mail to: <CGatePro-off@mail.stalker.com>
To switch to the DIGEST mode, E-mail to <CGatePro-digest@mail.stalker.com>
To switch to the INDEX mode, E-mail to <CGatePro-index@mail.stalker.com>
Send administrative queries to  <CGatePro-request@mail.stalker.com>
  

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster