Mailing List CGatePro@mail.stalker.com Message #97049
From: Nicolas Hatier <nicolas.hatier@niversoft.com>
Subject: Re: DNS
Date: Tue, 13 Jan 2009 00:07:57 -0500
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>

The first "error" is caused by the client connected to CGP identifying itself as [10.11.9.62]. This is not really an error but maybe a client hostname misconfiguration, and this is usually something you can ignore, especially from a client.

The second error is caused by a timeout in the PTR query for 65.115.10.2. I'm not sure what's causing this but this is the cause of a 15-seconds delay on your server. However your server or local DNS servers are unlikely to be the cause as they are not the authority that answers to PTR queries. When I tried to get a PTR answer for the same IP I got a 15 seconds delay and a failure too from here, so you may want to talk to your ISP or DNS provider about that , there seems to be a problem with the PTR DNS record for 65.115.10.2, or the DNS server which should answer to this query. Or maybe the timeout value on your server

It's possible that this query is done more than once, causing the 30-seconds delay you are seeing.

Regards,
Nicolas Hatier

Lyle Giese wrote:
Bob wrote:
Hi. Im getting complaints still of slow thunderbird connections to the cgate server, so I tried an email mself.  It seems to take about 30 seconds typical from the 'send' to it actually being sent via IMAP. Cgate logs are showing dns entry errors, but Im not sure where to look for solutions. Is it at the cgate side or the far side.
 
This example took about 20 seconds, but you can see the errors:

15:41:02.671 3 DNR-010234(2.10.115.65.IN-ADDR.ARPA) PTR:DNS server failure
15:41:02.796 5 SMTPI-012349([65.115.10.2]) out: 220 maxboostracing.com ESMTP CommuniGate Pro 5.2.11\r\n
15:41:03.000 5 SMTPI-012349([65.115.10.2]) inp: EHLO [10.11.9.62]
15:41:03.000 5 SMTPI-012349([65.115.10.2]) out: 250-maxboostracing.com your name is not [10.11.9.62]\r\n250-DSN\r\n250-SIZE 104857600\r\n250-STARTTLS\r\n250-AUTH LOGIN PLAIN CRAM-MD5 DIGEST-MD5 GSSAPI MSN NTLM\r\n250-ETRN\r\n250-TURN\r\n250-ATRN\r\n250-NO-SOLICITING\r\n250-8BITMIME\r\n250-HELP\r\n25
15:41:03.078 5 SMTPI-012349([65.115.10.2]) inp: AUTH CRAM-MD5
15:41:03.078 5 SMTPI-012349([65.115.10.2]) SASL-0(CRAM-MD5) out: <12349.1231792846@maxboostracing.com>
15:41:03.078 5 SMTPI-012349([65.115.10.2]) out: 334 PDEyMzQ5LjEyMzE3OTI4NDZAbWF4Ym9vc3RyYWNpbmcuY29tPg==\r\n
15:41:03.140 5 SMTPI-012349([65.115.10.2]) inp: Qm9iIDgzYzExMzMyYTBlMjljNzM5YWZiOWNiM2IwYmMwZGNj
15:41:03.140 5 SMTPI-012349([65.115.10.2]) SASL-0(CRAM-MD5) inp: Bob 83c11332a0e29c739afb9cb3b0bc0dcc
15:41:18.671 3 DNR-010241(2.10.115.65.IN-ADDR.ARPA) PTR:DNS server failure
15:41:18.671 2 SMTPI-012349([65.115.10.2]) 'mx@maxboostracing.com' connected from [65.115.10.2]:16341
15:41:18.671 2 SMTPI-012349([65.115.10.2]) 'mx@maxboostracing.com' disconnected ([65.115.10.2]:16341)
15:41:18.671 5 SMTPI-012349([65.115.10.2]) out: 235 mx relaying authenticated\r\n
15:41:18.921 5 SMTPI-012349([65.115.10.2]) inp: MAIL FROM:<bob@maxboostracing.com> SIZE=877
15:41:18.921 5 SMTPI-012349([65.115.10.2]) out: 250 bob@maxboostracing.com sender accepted\r\n
15:41:18.984 5 SMTPI-012349([65.115.10.2]) inp: RCPT TO:<fx@maxboostracing.com>
15:41:18.984 5 SMTPI-012349([65.115.10.2]) out: 250 fx@maxboostracing.com will leave the Internet\r\n
15:41:19.031 5 SMTPI-012349([65.115.10.2]) inp: DATA
15:41:19.031 5 SMTPI-012349([65.115.10.2]) out: 354 Enter mail, end with "." on a line by itself\r\n
15:41:19.187 2 SMTPI-012349([65.115.10.2]) [87593] received(mx), 1352 bytes
15:41:19.187 5 SMTPI-012349([65.115.10.2]) out: 250 87593 message accepted for delivery\r\n
15:41:19.187 2 QUEUE([87593]) from <bob@maxboostracing.com>, 1352 bytes (<496BAAA2.7050305@maxboostracing.com>)
  




Whatever you have configured for dns servers are not working or are way too busy or you have a firewall issue involving udp/tcp port 53.  Depending on  how CGPro is configured, CGPro could be looking at self configured services or OS specified dns servers.

It's also not that hard to setup a caching name server locally, whether windoze or Linux.

Lyle


--

Nicolas Hatier <nicolas.hatier@niversoft.com>
Niversoft idées logicielles - http://www.niversoft.com

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster