Mailing List CGatePro@mail.stalker.com Message #92462
From: Technical Support, Stalker Labs <support@stalker.com>
Subject: Re: [*] McAfee plugin 3.8 released
Date: Wed, 05 Sep 2007 16:00:44 +0400
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
Hello,
 Michael Zhang on 04.09.2007 6:20 wrote:

Hi, AllI faced one issue of McAfee incremental update with error code=17 on one Linux (x86_64) box. Anyone help me?10:14:15.02 4 EXTFILTER(McAfee) inp(54): * Incremental update CGPMcAfee/Updates/51105111AVV.GEM
10:14:15.02 4 EXTFILTER(McAfee) inp(54): * Incremental update CGPMcAfee/Updates/51075108AVV.GEM
10:14:15.02 4 EXTFILTER(McAfee) inp(54): * Incremental update CGPMcAfee/Updates/51065107AVV.GEM
10:14:15.02 4 EXTFILTER(McAfee) inp(54): * Incremental update CGPMcAfee/Updates/51055106AVV.GEM
10:14:15.02 4 EXTFILTER(McAfee) inp(54): * Incremental update CGPMcAfee/Updates/51085109AVV.GEM
10:14:15.02 4 EXTFILTER(McAfee) inp(54): * Incremental update CGPMcAfee/Updates/51095110AVV.GEM

It turns out that this error occurs when update files are picked in random order. If you're getting them in sequental order, it works, but I don't know what makes the filesystem to sort files returned by opendir/readdir. On my test machine the files are always in sorted order.

If you update files by one - it will work.

We'll try to release a new version which will sort the files internally.

10:14:15.02 4 EXTFILTER(McAfee) inp(44): * Starting the incremental update process...
10:14:18.18 4 EXTFILTER(McAfee) inp(105): * Incremental update failed, the engine returned error code=17; An error occured during updating the DATs
10:14:18.18 4 EXTFILTER(McAfee) inp(44): * Deleting CGPMcAfee/Updates/51105111AVV.GEM
10:14:18.18 4 EXTFILTER(McAfee) inp(44): * Deleting CGPMcAfee/Updates/51075108AVV.GEM
10:14:18.18 4 EXTFILTER(McAfee) inp(44): * Deleting CGPMcAfee/Updates/51065107AVV.GEM
10:14:18.18 4 EXTFILTER(McAfee) inp(44): * Deleting CGPMcAfee/Updates/51055106AVV.GEM
10:14:18.18 4 EXTFILTER(McAfee) inp(44): * Deleting CGPMcAfee/Updates/51085109AVV.GEM
10:14:18.18 4 EXTFILTER(McAfee) inp(44): * Deleting CGPMcAfee/Updates/51095110AVV.GEM
10:14:18.18 4 EXTFILTER(McAfee) inp(39): * Deleting CGPMcAfee/Updates/update.sig10:14:18.18 4 EXTFILTER(McAfee) inp(38): 30221 OK Changed license limit to 1000Best regards,Michael ZhangITC.H. Robinson Worldwide (China) Inc. ----- Original Message ----- From: "Technical Support, Stalker Labs" <support@stalker.com>
To: "CommuniGate Pro Discussions" <CGatePro@mail.stalker.com>
Sent: Saturday, August 25, 2007 1:45 AM
Subject: [*] McAfee plugin 3.8 released


Hello,

McAfee antivirus plugin version 3.8 has been released.


http://www.communigate.com/CGPMcAfee/


Platforms available:
* Linux-Intel (with libstdc++.so.6)
* Solaris-Sparc
* Windows-Intel
* AIX-PowerPC
* FreeBSD6-Intel
* MacOSX-UB (PowerPC+Intel, OSX version 10.4+)

Platforms expected to be released soon:
* Linux-x86_64
* HPUX-HPPA
* FreeBSD4-Intel
* OS/400-POWER


New features:
* McAfee Engine 5200
* Incremental updates of DAT files (saves a lot of traffic!!!)
* Easier installation (no need to move libraries into /usr/lib/)


-- Sincerely,
Roman



--
Sincerely,
Roman

=======================================================================
When answering to letters sent to you by the tech.support staff, make
sure the original message you have received is included into your reply.
Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster