Mailing List CGatePro@mail.stalker.com Message #92444
From: <freddy.frouin@bt.com>
Subject: RE: Linksys SPA3102 (Success!)
Date: Tue, 4 Sep 2007 15:47:55 +0100
To: <CGatePro@mail.stalker.com>
I did configured only 1 dial plan on the PTSN line setup:
DP1: (S0<:@gw0>)

My VoIP-to-PTSN Gateway settings tell to use this dial plan. Is there any issue with this ?

It was working fine from the phone plugged on LINE1 so I assumed it should have been working with VoIP users...

>-----Original Message-----
>From: CommuniGate Pro Discussions
>[mailto:CGatePro@mail.stalker.com] On Behalf Of Technical Support
>Sent: mardi 4 septembre 2007 16:44
>To: CommuniGate Pro Discussions
>Subject: Re: Linksys SPA3102 (Success!)
>
>Hello,
>
>freddy.frouin@bt.com wrote:
>> I did update for this:
>> - S:<+*@pstn> = gatewaycaller{00*}#pbx@domain ; start
>'gatewaycaller'
>> app
>>
>> In order the + to be replaced by 2 00. Yet, I still get the
>same 410 SIP code when I try to place a call... I think it's
>more an issue with the SPA3120 than with CGPro...
>
>Yes, the error is generate by SPA and means "the resource is
>not available any more" as if it refused to relay the call to
>PSTN That may be some dialplan setting in the PSTN line
>configuration of SPA...
>
>> Ideas are welcome.
>>
>> Regards, Freddy.
>>
>>> -----Original Message-----
>>> From: CommuniGate Pro Discussions
>>> [mailto:CGatePro@mail.stalker.com] On Behalf Of Technical Support
>>> Sent: mardi 4 septembre 2007 15:59
>>> To: CommuniGate Pro Discussions
>>> Subject: Re: Linksys SPA3102 (Success!)
>>>
>>> Hello,
>>>
>>> freddy.frouin@bt.com wrote:
>>>> Hello,
>>>>
>>>> Thanks for these details, I was able to go further with this
>>> information.
>>>> I've got a good news as well, I found some Cisco doc which
>>> details most of the SPA3102 options. I'm not sure I'm
>allowed to post
>>> it in this mailing list, so just ask me or if mailing list
>moderators
>>> accept it, I may post it there... Just let me know.
>>>> Then, I still have a problem:
>>>> - I'm login to CGPro with some account@domain (which is
>>> not the main domain of my cgp server)
>>>> - I've created a pbx@domain account with the privileges
>>> it was required to have as "Can access all files" and "Can
>>> Impersonate" and I added some call rules: redirected to #pbx.
>>>> - I've modified the router gatewaycaller rules to:
>>>> S:<*@pstn>    = gatewaycaller{*}#pbx@domain ;
>>> start 'gatewaycaller' app
>>>
>>> This entry will send the destination numbers as is,and per the logs
>>> below it appears the number is sent with the leading plus. You may
>>> need to change this router records to convert the number to the
>>> format accepted on the PSTN side. E.g. strip the plus sign and add
>>> leading 0:
>>>
>>> S:<+*@pstn> = gatewaycaller{0*}#pbx@domain ; start 'gatewaycaller'
>>> app
>>>
>>>
>>>> - I've modifyed PTSN account default in order to
>>> forward calls to the SPA3102.
>>>> Finally, when I try to make a PTSN call, the SPA3102 box
>>> answer with the 410 SIP code: "Gone" as shown in CGP Logs:
>>>> 14:25:57.557 5 SIP [0.0.0.0]:5060 -> [spa3102IP]:5061
>>> out(401): ACK sip:+somephonenumber@spa3102IP
>>> SIP/2.0\r\nP-Asserted-Identity: <sip:...
>>>> 14:25:57.557 2 SIPC-000072 [001424] ACK
>>> sip:+somephonenumber@spa3102IP
>>>> sent [cgproserverIP]:5060 -> udp [spa3102IP]:5061
>>> []
>>>
>>>> Does someone have any idea of what's going wrong ?
>>>>
>>>> I tried to make a call configuring my SIP client to directly
>>> access the SPA3102 and I've got exactly the same SIP return
>code when
>>> I try to place a call. So I'm not sure it's an issue with my CGP
>>> setup, but I'm not sure with it as well...
>>>> Thanks,
>>>> Best Regards, Freddy.
>>>>
>>>>> -----Original Message-----
>>>>> From: CommuniGate Pro Discussions
>>>>> [mailto:CGatePro@mail.stalker.com] On Behalf Of Technical Support
>>>>> Sent: lundi 3 septembre 2007 20:16
>>>>> To: CommuniGate Pro Discussions
>>>>> Subject: Re: Linksys SPA3102 (Success!)
>>>>>
>>>>> Hello,
>>>>>
>>>>> freddy.frouin@bt.com wrote:
>>>>>> Hello everyone,
>>>>>>
>>>>>> Well, I'm interested with what you said in this thread, I'd
>>>>> like to get more details about it. Where you able to manage
>>> all your
>>>>> calls, incoming and outgoing calls, from a CGPro account ?
>>>>>> I'm now able to place and receive calls from the LINE1 RJ11
>>>>> port. I'm able as well to forward incoming calls to LINE1
>to an SIP
>>>>> account on the CGPro server using the User LINE1
>settings. Yet, I'm
>>>>> still unable to place a call from a SIP/CGPro account to
>>> the SPA3102.
>>>>> Note that the FXS account in Sipura 3102 uses a different
>>> port number
>>>>> by default (5061, if my memory serves). You need to relay
>requests
>>>>> from CGPro (better - through gatewaycaller
>>>>> script) to that port. Sending request on the standard port
>>> 5060 would
>>>>> give you some error (403 Forbidden, I believe.)
>>>>>
>>>>>> I tried to configure the WAN interface instead of using the
>>>>> LAN one, because I finished to think the SIP gateway was
>maybe only
>>>>> available on the WAN interface... ? I do not need to use the WAN
>>>>> interface 'cause I already have another router... But
>when I switch
>>>>> to the WAN interface, the management interface is no more
>>> available,
>>>>> neither in HTTP, nor in HTTPS...
>>>>>
>>>>> That's on WAN settings page (which you need to access while
>>> connected
>>>>> through the LAN port): Enable WAN Web Server: -- set that
>>> to yes. And
>>>>> we connect the device to the office network through its WAN port.
>>>>>
>>>>>> Any help would be appreciated,
>>>>>> Best Regards, Freddy.
>>>>>>
>>>>>>> -----Original Message-----
>>>>>>> From: CommuniGate Pro Discussions
>>>>>>> [mailto:CGatePro@mail.stalker.com] On Behalf Of Ifan Jones
>>>>>>> Sent: lundi 13 août 2007 12:34
>>>>>>> To: CommuniGate Pro Discussions
>>>>>>> Subject: Re: Linksys SPA3102 (Success!)
>>>>>>>
>>>>>>> I just completed a successful pstn - SIP call through the SPA
>>>>>>> 3102
>>>>>>>
>>>>>>> The SPA has two network ports as it has a built in router -
>>>>> I didn't
>>>>>>> need this so I enabled the WAN side (marked inernet)
>management,
>>>>>>> assigned a static IP, and disconnected the LAN side (marked
>>>>>>> ethernet), and hey presto everything came to life!
>>>>>>>
>>>>>>> I'll be documenting this soon and will post my settings
>>> and configs
>>>>>>> for others to use.
>>>>>>>
>>>>>>> Regards
>>>>>>>
>>>>>>> Ifan Jones
>>>>>>> Solet Ltd
>>>>>>>
>>>>>>> w: www.solet.co.uk
>>>>>>> e: ifan@solet.co.uk
>>>>>>> t: 08701995007
>>>>>>>
>>>>>>> sip: 201@soletsupport.co.uk
>>>>>>>
>>>>>>> On Monday, Aug. 13, 2007 at 8:22
>>>>>>>  "Ifan Jones"  wrote:
>>>>>>>
>>>>>>>> :-)  I agree - the doumentation is awful, perhaps once we get
>>>>>>> these working we should provide a guide!
>>>>>>>> Ifan Jones
>>>>>>>> Solet Ltd
>>>>>>>>
>>>>>>>> w: www.solet.co.uk
>>>>>>>> e: ifan@solet.co.uk
>>>>>>>> t: 08701995007
>>>>>>>>
>>>>>>>> sip: 201@soletsupport.co.uk
>>>>>>>>
>>>>>>>> On Monday, Aug. 13, 2007 at 8:33  freddy.frouin@bt.com wrote:
>>>>>>>>
>>>>>>>>> So, I finally tried it but not successfully for the moment:
>>>>>>>>> - I had some problem to connect it to the french PTSN,
>>>>>>> if someone has any details about this, would be interesting.
>>>>>>> It's maybe a boring issue, don't know...
>>>>>>>>> - I don't find out detailed documentation about the
>>>>>>> SPA3102. Manufacturer documentation is really poor
>>> compared to all
>>>>>>> available options.
>>>>>>>>> - I was able to make it authenticate using SIP to CGPro
>>>>>>> server. But then, I would like another users of the CGP
>>>>> server to be
>>>>>>> able to access the PTSN through this user, but I still
>>>>> don't know if
>>>>>>> it will be possible to do so.
>>>>>>>>> - My first idea was to access the SPA3102 as a media
>>>>>>> gateway configuring an SIP gateway in CGPro and to route
>>>>> calls to it,
>>>>>>> but from what I look to understand of the SPA3102 config I
>>>>> think it's
>>>>>>> a wrong way, it won't allow such configuration. Did
>someone ever
>>>>>>> tried this ?
>>>>>>>>> Thanks,
>>>>>>>>> Best Regards, Freddy.
>>>>>>>>>
>>>>>>>>>> -----Original Message-----
>>>>>>>>>> From: CommuniGate Pro Discussions
>>>>>>> [mailto:CGatePro@mail.stalker.com]
>>>>>>>>>> On Behalf Of Ifan Jones
>>>>>>>>>> Sent: mercredi 8 août 2007 18:54
>>>>>>>>>> To: CommuniGate Pro Discussions
>>>>>>>>>> Subject: Linksys SPA3102
>>>>>>>>>>
>>>>>>>>>> Hi All
>>>>>>>>>>
>>>>>>>>>> This is the newer version of the SPA3000 - anyone here had
>>>>>>> the honour of setting one up for CGPro?
>>>>>>>>>> Ifan Jones
>>>>>>>>>> Solet Ltd
>>>>>>>>>>
>>>>>>>>>> w: www.solet.co.uk
>>>>>>>>>> e: ifan@solet.co.uk
>>>>>>>>>> t: 08701995007
>>>>>>>>>>
>>>>>>>>>> sip: 201@soletsupport.co.uk
>>>>>>>>>>
>>> --
>>> Best regards,
>>> Dmitry Akindinov
>>>
>>>
>=====================================================================
>>> == When answering to letters sent to you by the tech.support staff,
>>> make sure the original message you have received is included into
>>> your reply.
>>>
>>>
>>> #############################################################
>>> This message is sent to you because you are subscribed to  the
>>> mailing list <CGatePro@mail.stalker.com>.
>>> To unsubscribe, E-mail to: <CGatePro-off@mail.stalker.com>
>To switch
>>> to the DIGEST mode, E-mail to <CGatePro-digest@mail.stalker.com>
>>> To switch to the INDEX mode, E-mail to
>>> <CGatePro-index@mail.stalker.com> Send administrative queries to  
>>> <CGatePro-request@mail.stalker.com>
>>>
>>
>> #############################################################
>> This message is sent to you because you are subscribed to
>>   the mailing list <CGatePro@mail.stalker.com>.
>> To unsubscribe, E-mail to: <CGatePro-off@mail.stalker.com> To switch
>> to the DIGEST mode, E-mail to <CGatePro-digest@mail.stalker.com>
>> To switch to the INDEX mode, E-mail to
>> <CGatePro-index@mail.stalker.com> Send administrative queries to  
>> <CGatePro-request@mail.stalker.com>
>
>--
>Best regards,
>Dmitry Akindinov
>
>=======================================================================
>When answering to letters sent to you by the tech.support
>staff, make sure the original message you have received is
>included into your reply.
>
>
>#############################################################
>This message is sent to you because you are subscribed to
>  the mailing list <CGatePro@mail.stalker.com>.
>To unsubscribe, E-mail to: <CGatePro-off@mail.stalker.com> To
>switch to the DIGEST mode, E-mail to <CGatePro-digest@mail.stalker.com>
>To switch to the INDEX mode, E-mail to
><CGatePro-index@mail.stalker.com> Send administrative queries
>to  <CGatePro-request@mail.stalker.com>
>
Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster