Mailing List CGatePro@mail.stalker.com Message #92418
From: Sherif Aboul Gadayel <postmaster@cg.mist.com.eg>
Subject: Re: SpamAssassin Time out
Date: Sun, 02 Sep 2007 09:14:00 +0300
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
Bret Miller wrote:
I have an " external helper timed out " problem with SpamAssassin
it happens about 5 times a week the SpamAssassin stops ( time out ) and this cause all incoming messages to stop in the Queue

I am running
cgpsa script  v 1.76
perl, v5.8.5 built for i386-linux-thread-multi
SpamAssassin Version 3.1.7 (2006-10-05)

Did anybody have this problem before ? any updates needed to solve it ?
    

I've seen timeout periodically, generally caused by delays in DNS, or
occasionally a badly-formatted message. What's the time-out value for the
helper? Do you have to remove any messages to get it working again? If not,
how about setting a restart time so that it starts itself back up. I realize
this makes it more difficult to see if there was an error, but if it's
intermittent, getting the queue moving is generally priority.

If the same message doesn't cause it to time out when run a second time, I'd
guess you either have a DNS issue where DNS is taking longer to complete
than your timeout value allows, or you have a timing issue where SA is
getting lost at some point in SA. Of course, neither perl nor SA are on
their current versions... I had considerable issues with perl multithreading
on Windows prior to 5.8.6. However, it was my understanding that this was a
windows-only issue.

About the only way to figure out what's happening is to have debug logging
so you can see where SA went wrong. Bret

  
The timeout is 3 minutes .
I will try the debug logging

--
Sherif Aboul Gadayel

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster