Mailing List CGatePro@mail.stalker.com Message #92008
From: A Ballesteros <ab@communigate.com>
Subject: Re: iCal publishing CGate Pro 5.1.11
Date: Tue, 31 Jul 2007 09:57:57 -0700
To: <CGatePro@mail.stalker.com>
X-Mailer: Pronto CommuniGate 1.2k
On Mon, 30 Jul 2007 10:25:49 -0400
 Kirk Gleason <kgleason@finelight.com> wrote:
Has anyone noticed any problems publishing Calendars from iCal on  CGate Pro v 5.1.11? Since I upgraded to 5.1.11 I have not been able  to successfully publish my calendar from iCal, but I can successfully  subscribe to other people calendars. This seems to have broken in 5.1.11 (in 5.1.10 it was working).

Hello, I may be out of date on what is possible with Apple's iCal and CommuniGate Pro. I have always been able to subscribe to calendars hosted on CommuniGate Pro and publishing works only as the client allows, from a local calendar.

CommuniGate Pro was version 4.3 when I last wrote about this:
http://mail.communigate.com/~ab/files/iCal-CGP.html

I am confused about what broke in your installation. I have performed some tests using a 5.1.11 server and the newer install where we offer free test accounts at http://talktoip.com. In all tests I was able to create an event in a local iCal calendar and have that auto publish to the remote CommuniGate Pro calendar as iCal is designed to work.
 
The URL I am try to use for publishing in iCal looks like this:

http://mail.domain.tld:9100/CalendarData/~<username>/

There may be a problem with this URL. You have http and port 9100. By default port 9100 is for https and port 8100 is for http. Could this be the problem?

And the Calendar is named Calendar. iCal used to automatically append  the Calendar.ics onto the end of the URL, and based on the error  message I am getting back from iCal, it looks like it is still  happening like that.

I will provide the configuration I used for http://talktoip.com. I could not use https because we do not yet have an https certificate installed there yet. If you try with https on talktoip.com iCal returns a certificate error as expected.

First I subscribe to my remote calendar on talktoip.com:

http://talktoip.com/CalendarData/~ab/Calendar.ics

I name this calendar ab@talktoip.com

I then create a local calendar called talktoip.com. I right-click and select Publish and choose the private server option. The data for the form I entered is:

Publish Calendar as: Calendar
Base URL: http://talktoip.com/CalendarData/~ab
login: ab
pass: supersecretstuff (not the real pass)

I activated all check boxes, clicked on the Publish button and it works. This also works as expected on a 5.1.11 test server I have.

Regards,
Azdio
Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster