Mailing List CGatePro@mail.stalker.com Message #106757
From: Gib Henry Gib@GibHenry.com <CGatePro@mail.stalker.com>
Subject: Re: CGPro regularly disappears for several seconds
Date: Mon, 19 Feb 2018 12:15:17 -0600
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>

Not sure whether this is related, but on my Mac, I see these for hours at a time for reasons unknown to me (the machine seems to be running fine during these episodes, I can’t find anything odd in the system log, and they eventually clear by themselves):

18:56:32.556 0 SYSTEM CPU overloaded: main thread missed 5 seconds
18:57:47.549 0 SYSTEM CPU overloaded: main thread missed 10 seconds
18:58:52.534 0 SYSTEM CPU overloaded: main thread missed 12 seconds
18:59:57.521 0 SYSTEM CPU overloaded: main thread missed 12 seconds
19:01:02.532 0 SYSTEM CPU overloaded: main thread missed 12 seconds
19:02:07.534 0 SYSTEM CPU overloaded: main thread missed 12 seconds
19:03:12.537 0 SYSTEM CPU overloaded: main thread missed 11 seconds
19:04:17.536 0 SYSTEM CPU overloaded: main thread missed 12 seconds
19:05:22.534 0 SYSTEM CPU overloaded: main thread missed 12 seconds
19:06:27.537 0 SYSTEM CPU overloaded: main thread missed 12 seconds
19:07:32.534 0 SYSTEM CPU overloaded: main thread missed 12 seconds
19:08:37.533 0 SYSTEM CPU overloaded: main thread missed 12 seconds
19:09:42.533 0 SYSTEM CPU overloaded: main thread missed 12 seconds
19:10:47.533 0 SYSTEM CPU overloaded: main thread missed 12 seconds
Cheers,
--
Gib Henry


On 2/19/18 12:03 PM, James Moe jimoe@sohnen-moe.com wrote:
CGpro v6.1.19
linux v4.4.104-39-default x86_64

  On a regular basis, something like every 10 - 20 minutes, CGPro
does... something, for 5 - 15 seconds. During that time it delays
interactions with MUAs. From the user's point of view it all they see is
the busy spinner. It is annoying.
  There is nothing in the server's logs to indicate the momentary
catatonia. There is nothing in the system logs.
  This is something that became noticeable several versions ago,
somewhere around 6.1.12. It has become more of an issue with each upgrade.
  The only clue I have is what "nmon" displays in its CPU usage: a spike
in CPU usage, up to 70%, consisting of wait states. These always occur
when CGPro is briefly unavailable.
  Access to the server is on our local network, not from the Internet.
  We have a couple of helpers running, one each for DKIM and DMARC.

  Can anyone suggest what may be happening? Or how to discover what is
happening.


Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster