Mailing List Message #106157
From: Roberto Michelena <>
Subject: Re: PBX
Date: Tue, 30 Aug 2016 17:26:00 -0500
To: CommuniGate Pro Discussions <>
X-Mailer: Apple Mail (2.3124)
Well this is quite interesting but also a sure source of frustration…!
I can’t even manage the Pronto clients to connect properly!

After trying hard I did manage to get the Cisco phones to register, and also to call each other. But no audio came out. Ever.
So I tried calling from Pronto iOS clients. Same thing. Between two Pronto iOS clients. Same. and Between web and iOS Pronto clients. Same.

So I grabbed a old MacMini I had lying around, did a fresh OS install and a fresh CGPro (latest) install. (no license = community edition)
Invented a domain ( and created a domain alias with the IP address in order to log in from other computers.
Created a couple of accounts, Joe and Bob. Added aliases (for extension numbers) 210 and 211 to Joe and Bob.
Logged in Joe and Bob from Pronto browser clients in separate computers, and couldn’t even connect calls. “no address”. I tried chatting and sending emails between Joe and Bob, worked perfectly.

It turns out, it seems, that the problem was logging into the server by IP address and not domain name. Because as soon as I added the fake domain to my DNS server, the calls began connecting. Your browser connection needs to be by domain name not IP address.
But no audio. Joe and Bob can ring each other from their browsers, the call loudly rings and “connects”, but then it’s all silence.

So I decided to try iOS Pronto clients. iPad to browser. Browser to iPad. Same.

On Firefox (mac) it seemed to work without plugin, by “WebRTC wrapper” ; but audio was only one way, actually no, it was feeding back to the same browser window from which it was originating.
Then after installing the plugin, the plugin kept crashing and that was the end of any audio.

Chrome insisted to have a secure connection. I generated a self-signed certificate on the server and after getting past Chrome’s complaints, logged in. No audio either on the calls. No option to install plugin, only WebRTC wrapper.

To make it short, every browser is a different story but there’s no audio from or to any of them, except briefly some feedback loop within Firefox. And also white noise. Also tried Firefox under Win7, white noise.
Explorer 8 under Win7, wants to install a plugin but then does not find it.

Safari, after installing the media plugin, also no audio at all, and frequent “illegal command parameter” errors when receiving a call.

I did get iOS to iOS to work on the “fresh” install. The only situation in which I finally got two-way audio between Pronto clients.
But when I try in on my real server which belongs to two networks, it does not work. Connects but no audio. Arghhh.

It’s not the audio input or output devices or their hooks to the software. Leaving voicemail works. If I put on hold from one side, the other hears music. Well, sometimes that works sometimes not, no music. And sometimes you put one party on hold and then when you resume, the other party keeps getting music.

So conceptually everything is beautifully thought and even graphically well executed. I only wish it worked!
Has anyone got Pronto browser clients to work reliably for voice communication?

Roberto Michelena

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster