Mailing List CGatePro@mail.stalker.com Message #105623
From: Shaun Gamble <listrdr@redco.com.au>
Subject: Re: SpamAssassin 3.4.x on Windows
Date: Thu, 07 May 2015 09:27:37 +1000
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
Yes, I didn't think to warn you about nmake no longer being used. A number of other things changed slightly as well but you only notice if you carefully watch the compilation of things like SA.

The nmake/dmake thing had me for a while.

On 7/05/2015 12:06 AM, Bret Miller wrote:
I was trying to install on a brand new install of Windows 8.1 64-bit running ActivePerl 5.20.2 x86. At some point ActivePerl seems to have forced the use of dmake instead of nmake on Windows. My guess is that's the problem rather than the perl version itself. I assume you'd do this anyway, but before you try upgrading on your live server, try it in a test environment in case you run into the same issues I did.

On 5/5/2015 3:25 PM, Shaun Gamble wrote:
I'm on Windows 2012 (x64) using ActivePerl 5.14.2 I was going to update pretty soon. Running Perl on Windows just takes so much effort to keep it up to date. What version are you running?

I know I had to basically uninstall SA (deleting all existing folders, etc) before I could get it to work. Oh and another thing, do not run the 64bit version of AP on Windows. Even though I have a 64bit OS, nothing would run properly until I uninstalled x64 Perl and ran 32bit Perl. I don't know if that is your problem or not.

On 6/05/2015 1:03 AM, Bret Miller wrote:
I was using SA 3.3.2 with CGPSA. Maybe I'm using too new a version of ActivePerl. Trying to make SA 3.4.0 just keeps failing. Glad it's just me.

For me, the simpler approach works better anyway as long as JAM Software keeps making their Windows version.

On 5/4/2015 4:48 PM, Shaun Gamble wrote:
I'm still using CGPSA with SA 3.4.0 on Windows using Perl. I've only just noticed 3.4.1 is out. Which version did you have the errors? Or were you not using SA with CGPSA?

On 5/05/2015 5:50 AM, Bret Miller wrote:
Has anyone successfully installed the native perl version SpamAssassin 3.4.0 or 3.4.1 on Windows? I just keep getting errors.

I finally gave up and decided to write my own simple interface to spamc. This should be OS-independent as long as you can install spamc and spamd on your platform. For Windows, it means you can use SpamAssassin for Windows (http://www.jamsoft.net/spamassassin/) which greatly simplifies installation and adds some tools that were near-impossible to compile (like Razor2). Currently it uses only global configuration and adds headers to the message. This suits my needs so I'm unlikely going to expand it further.

You can find it here: https://github.com/bret-miller/cgSpamAssassin. Use at your own risk.




-- 

Shaun
Fitzroy Island <http://www.fitzroyisland.com>
Destination Darwin NT <http://www.destinationnt.com>
MOM Backpackers <http://www.momdarwin.com>
Value Inn Hotel <http://www.valueinn.com.au>
Please do not send any unsolicited email. It is not wanted. 


-- 

Shaun
Fitzroy Island <http://www.fitzroyisland.com>
Destination Darwin NT <http://www.destinationnt.com>
MOM Backpackers <http://www.momdarwin.com>
Value Inn Hotel <http://www.valueinn.com.au>
Please do not send any unsolicited email. It is not wanted. 
Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster