Mailing List CGatePro@mail.stalker.com Message #105352
From: Robert Opalko <opalko@oxfordms.net>
Subject: SMTPI protocol errors
Date: Wed, 10 Dec 2014 11:31:01 -0600
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
I am trying to diagnose why I cannot set up Iphones with our CGPro 6.0.10 server (x64).  You can see the connection transaction in the system log below.    166.172.58.102 is the address of the phone. fuddles is a temporary account set up to test with.

What are the errors in the log from 10:06:40.691 to 10:06:40.723?

Also, what is the address listed at time 10:06:51.067 (10.33.64.161)???

A transcript of an initial setup is below:

10:28:47.712 5 SMTP [0.0.0.0]:587 <- [166.172.58.102]:35589 connection request. socket=513
110:28:47.403 5 SMTP new VStream created, 1 total
10:28:47.426 5 SMTP stream thread started
10:28:47.426 4 SMTPI-011552([166.172.58.102]) [192.168.200.100]:587 <- [166.172.58.102]:58863 incoming connection(oxfordms.net)
10:28:47.426 5 SMTPI-011552([166.172.58.102]) out: 220 oxfordms.net ESMTP CommuniGate Pro 6.0.10\r\n
10:28:47.433 5 SMTPI-011552([166.172.58.102]) inp: \022\003\001
10:28:47.712 5 SMTP [0.0.0.0]:587 <- [166.172.58.102]:35589 connection request. socket=513
10:28:47.712 5 SMTP new VStream created, 2 total
10:28:47.712 5 SMTP stream thread started
10:28:47.713 4 SMTPI-011553([166.172.58.102]) [192.168.200.100]:587 <- [166.172.58.102]:35589 incoming connection(oxfordms.net)
10:28:47.713 5 SMTPI-011553([166.172.58.102]) out: 220 oxfordms.net ESMTP CommuniGate Pro 6.0.10\r\n
10:28:47.822 5 SMTPI-011553([166.172.58.102]) inp: EHLO [10.85.58.197]
10:28:47.823 5 SMTPI-011553([166.172.58.102]) out: 250-oxfordms.net your name is not [10.85.58.197]\r\n250-DSN\r\n250-SIZE\r\n250-STARTTLS\r\n250-AUTH LOGIN PLAIN CRAM-MD5 GSSAPI\r\n250-ETRN\r\n250-TURN\r\n250-ATRN\r\n250-NO-SOLICITING\r\n250-8BITMIME\r\n250-HELP\r\n250-PIPELINING\r\n250 EHLO\r\n
10:28:47.942 5 SMTPI-011553([166.172.58.102]) inp: STARTTLS
10:28:47.942 5 SMTPI-011553([166.172.58.102]) out: 220 please start a TLS connection\r\n
10:28:48.358 4 SMTPI-011553([166.172.58.102]) TLSv1.0 security initiated
10:28:48.442 4 SMTPI-011553([166.172.58.102]) TLS-102382(AES128_SHA) connection accepted for 'oxfordms.net'
10:28:48.692 5 SMTPI-011553([166.172.58.102]) s-inp: EHLO [10.85.58.197]
10:28:48.692 5 SMTPI-011553([166.172.58.102]) s-out: 250-oxfordms.net your name is not [10.85.58.197]\r\n250-DSN\r\n250-SIZE\r\n250-AUTH LOGIN PLAIN CRAM-MD5 GSSAPI\r\n250-ETRN\r\n250-TURN\r\n250-ATRN\r\n250-NO-SOLICITING\r\n250-8BITMIME\r\n250-HELP\r\n250-PIPELINING\r\n250 EHLO\r\n
10:28:48.952 5 SMTPI-011553([166.172.58.102]) s-inp: AUTH PLAIN AGZ1ZGRsZXMAMWJpZ2RvZw==
10:28:48.952 5 SMTPI-011553([166.172.58.102]) SASL(PLAIN) ini: \000fuddles\000zaZZ1eloP0p\000
10:28:48.952 2 SMTPI-011553([166.172.58.102]) 'fuddles@oxfordms.net' connected(CLRTXT) [166.172.58.102]:35589->[192.168.200.100]:587(tls)
10:28:48.952 2 SMTPI-011553([166.172.58.102]) 'fuddles@oxfordms.net' disconnected ([166.172.58.102]:35589)
10:28:48.952 2 SMTPI-011553([166.172.58.102]) authenticated as fuddles@oxfordms.net
10:28:48.952 5 SMTPI-011553([166.172.58.102]) s-out: 235 fuddles@oxfordms.net relaying authenticated\r\n
10:28:49.072 5 SMTPI-011553([166.172.58.102]) s-inp: QUIT
10:28:49.072 5 SMTPI-011553([166.172.58.102]) s-out: 221 oxfordms.net CommuniGate Pro SMTP closing connection\r\n
10:28:49.072 4 SMTPI-011553([166.172.58.102]) TLS connection is closing
10:28:49.072 4 SMTPI-011553([166.172.58.102]) closing connection
10:28:49.072 4 SMTPI-011553([166.172.58.102]) releasing stream
10:28:49.436 5 SMTPI-011552([166.172.58.102]) out: 501 Unknown command\r\n
10:28:49.436 5 SMTPI-011552([166.172.58.102]) inp: \163\001
10:28:51.438 5 SMTPI-011552([166.172.58.102]) out: 501 Unknown command\r\n
10:28:51.438 3 SMTPI-011552([166.172.58.102]) write failed. Error Code=broken connection
10:28:51.438 5 SMTPI-011552([166.172.58.102]) inp:
10:28:53.440 5 SMTPI-011552([166.172.58.102]) out: 501 Unknown command\r\n
10:28:53.440 3 SMTPI-011552([166.172.58.102]) write failed. Error Code=broken connection
10:28:53.440 5 SMTPI-011552([166.172.58.102]) inp: \159\003\001T\135%\153\162k\217\160\136Y\139\206a\138\224\253e\028\186\135Eh\148=6\185;2=\191\164s
10:28:55.442 5 SMTPI-011552([166.172.58.102]) out: 501 Unknown command\r\n
10:28:55.442 3 SMTPI-011552([166.172.58.102]) write failed. Error Code=broken connection
10:28:55.442 5 SMTPI-011552([166.172.58.102]) inp:
10:28:57.444 5 SMTPI-011552([166.172.58.102]) out: 501 Unknown command\r\n
10:28:57.444 3 SMTPI-011552([166.172.58.102]) write failed. Error Code=broken connection
10:28:57.444 1 SMTPI-011552([166.172.58.102]) Too many protocol errors, aborting. [166.172.58.102] is blacklisted for 600 seconds
10:28:57.444 4 SMTPI-011552([166.172.58.102]) closing connection
10:28:57.444 4 SMTPI-011552([166.172.58.102]) releasing stream
10:29:04.000 5 SMTP stream thread finished
10:29:12.000 5 SMTP stream thread finished

The device gets blacklisted because of the protocol errors.  I have been able to get the devices set up by eithe r choosing the Exchange option instead of IMAP but that is not a good solution - IMAP should work.  I have also tried increasing the number of protocol errors allowed (in Settings>SMTP>Receiving>Limits>Non-client sender).  But can anyone tell me what are and why are the errors occurring in the first place?  I currently accept mail on 25, 587 and 465 (SSL on) 

I do not get these errors setting up IMAP on other devices.

Regards,
Robert Opalko

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster