Mailing List CGatePro@mail.stalker.com Message #104347
From: Jonathan Weinraub <jonathan@weinraub.net>
Subject: cgpsa problems...
Date: Thu, 18 Jul 2013 11:20:13 -0400
To: <CGatePro@mail.stalker.com>
X-Mailer: CommuniGate Pro WebUser v5.3.13
I am trying to enable the cpgpsa with CLI so I can have spammy messages go into my users SPAM folders rather than the inbox.

I had followed the documentation to the letter and I keep getting the same errors.

weinraub:/var/CommuniGate/Settings# cat cgpsa.err
* Thu Jul 18 01:24:09 2013 Standard Error Redirected By TFF Enterprises CGPSA Filter 1.7
* Thu Jul 18 01:24:51 2013 CGPSA Error: Could not connect to CLI, exiting

10:17:32.022 4 EXTFILTER(cgpsa) inp(043): * TFF Enterprises CGPSA Filter 1.7 Starting
10:17:32.022 4 EXTFILTER(cgpsa) inp(065): * Loading Configuration File /var/CommuniGate/Settings/cgpsa.conf
10:17:32.024 4 EXTFILTER(cgpsa) inp(058): *  Attempting to load domain configuration for main domain
10:17:32.024 4 EXTFILTER(cgpsa) inp(043): *  Using root configuration for main domain
10:17:32.024 4 EXTFILTER(cgpsa) inp(027): * Configuration File Loaded
10:17:32.024 4 EXTFILTER(cgpsa) inp(028): * Parallel Requests Mode: On
10:17:33.643 5 EXTFILTER(cgpsa) ENQUEUER-1 starting initialization
10:17:33.643 4 EXTFILTER(cgpsa) out(010): 34 INTF 3\n
10:17:33.679 4 EXTFILTER(cgpsa) ENQUEUER-3 waiting for initialization
10:17:33.680 4 EXTFILTER(cgpsa) inp(047): * Using SpamAssassin Version 3.3.2 (2011-06-06)
10:17:33.680 4 EXTFILTER(cgpsa) inp(042): * Default SpamAssassin Settings Location: 
10:17:33.680 4 EXTFILTER(cgpsa) inp(030): *     (local.cf settings only)
10:17:33.680 4 EXTFILTER(cgpsa) inp(025): * Initialization Complete
10:17:33.680 4 EXTFILTER(cgpsa) inp(040): * TFF Enterprises CGPSA Filter 1.7 Ready
10:17:33.680 4 EXTFILTER(cgpsa) inp(009): 34 INTF 2
10:17:33.680 2 EXTFILTER(cgpsa) interfaceLevel = 2
10:17:33.680 2 EXTFILTER(cgpsa) inited
10:17:33.680 4 EXTFILTER(cgpsa) out(025): 35 FILE Queue/260010.msg\n
10:17:33.686 4 EXTFILTER(cgpsa) out(025): 36 FILE Queue/260017.msg\n
10:17:33.691 4 EXTFILTER(cgpsa) out(025): 37 FILE Queue/230003.msg\n
10:17:33.691 4 EXTFILTER(cgpsa) out(025): 38 FILE Queue/230001.msg\n
10:17:33.691 4 EXTFILTER(cgpsa) out(025): 39 FILE Queue/260004.msg\n
10:17:33.695 4 EXTFILTER(cgpsa) out(025): 40 FILE Queue/230004.msg\n
10:17:33.695 4 EXTFILTER(cgpsa) out(025): 41 FILE Queue/220005.msg\n
10:17:33.700 4 EXTFILTER(cgpsa) out(025): 42 FILE Queue/220001.msg\n
10:17:33.714 4 EXTFILTER(cgpsa) inp(044): * 34 Checking for CommuniGate Pro CLI Access
10:17:33.715 4 EXTFILTER(cgpsa) inp(076): * 34 Could not connect to CLI (Error: Can't open connection to CGPro Server)
10:17:33.715 4 EXTFILTER(cgpsa) inp(048): * 34 Sleeping for 20 seconds before next attempt

If I do a manual PWD from telnet it works:

 
weinraub:/var/CommuniGate/Settings# telnet mail.weinraub.net 106
Trying 66.187.98.200...
Connected to mail.weinraub.net.
Escape character is '^]'.
200 CommuniGate Pro PWD Server 5.3.13 ready <zzzzz@mail.weinraub.net>
USER cgpsa-user
300 please send the PASS
PASS cgpsa-pass
200 login OK, proceed
CreateAccount "user1"
200 OK

Any ideas???

Thanks,

Jon
Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster